Jump to content
Ordering & InfoSupport ForumSupport DeskContact UsEmail Sign-UpReseller Finder

Inside tank still looks a little rusty


bwallis42
 Share

Recommended Posts

The inside of my tank still looks a bit rusty after cleaning and rustblast. I kept the inside of the tank wet with the rustblast for about an hour, turning and shaking it every 5 minutes or so. Drained it out and washed out the tank and dried it well with a heat gun. Examining what I can see of the inside of the tank I can still see areas that look a bit red with rust. Its not a lot but more than a little.  The photo shows a bit of it, there are similar but larger areas inside the tank.

Is this OK. Do I just proceed with the sealer or should I re-use the rust blast again or get some more?

thanks.

 

20150607_193851.jpg

Link to comment
Share on other sites

It looks like the loose flaky rust has been removed (happened during the KBS Klean step) and the surface rust has been etched really well with the RustBlast. Because your time frames for allowing the RustBlast to etch the inside of the tank are correct, please proceed with confidence to the Tank Sealer step.

If you have any additional questions, please feel free to contact us.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...